SimbaProSignals: Auflistung der Klassen

  • Hauptseite
  • Klassen
  • Dateien
  • Auflistung der Klassen
  • Klassen-Elemente

SimbaProSignals Auflistung der Klassen

Hier folgt die Aufzählung aller Klassen, Strukturen, Varianten und Schnittstellen mit einer Kurzbeschreibung:
SignalList
Erzeugt am Thu Dec 13 12:56:24 2007 für SimbaProSignals von doxygen 1.5.4


SimbaProSignals: SignalList Klassenreferenz

  • Auflistung der Klassen
  • Klassen-Elemente

SignalList Klassenreferenz

#include <signallist.h>

Aufstellung aller Elemente

Öffentliche Methoden

SignalList (String^)
virtual String requireModule ()=0

Ausführliche Beschreibung

Definiert in Zeile 1 der Datei signallist.h.

Beschreibung der Konstruktoren und Destruktoren

SignalList::SignalList ( String^ name )

Definiert in Zeile 3 der Datei signallist.cpp.

Dokumentation der Elementfunktionen

virtual String SignalList::requireModule ( ) [pure virtual]

Die Dokumentation für diese Klasse wurde erzeugt aufgrund der Dateien:
  • signallist.h
  • signallist.cpp


SimbaProSignals: Klassen-Elemente

  • Auflistung der Klassen
  • Klassen-Elemente
  • Alle
  • Funktionen
Hier folgt die Aufzählung aller Klassenelemente mit Verweisen auf die zugehörigen Klassen:

  • requireModule() : SignalList
  • SignalList() : SignalList


SimbaProSignals: Datei-Verzeichnis

SimbaProSignals Auflistung der Dateien

Hier folgt die Aufzählung aller Dateien mit einer Kurzbeschreibung:
signallist.cpp [code]
signallist.h [code]


SimbaProSignals: signallist.cpp-Dateireferenz

signallist.cpp-Dateireferenz

#include "SignalList.h"

Include-Abhängigkeitsdiagramm für signallist.cpp:

gehe zum Quellcode dieser Datei


SimbaProSignals: signallist.h-Dateireferenz

signallist.h-Dateireferenz

Dieser Graph zeigt, welche Datei direkt oder indirekt diese Datei enthält:

gehe zum Quellcode dieser Datei

Klassen

class SignalList


SimbaProSignals: Elementverzeichnis

  • Auflistung der Klassen
  • Klassen-Elemente

SignalList Elementverzeichnis

Vollständige Aufstellung aller Elemente für SignalList einschließlich aller geerbten Elemente.

requireModule()=0 | SignalList | [pure virtual]
SignalList(String^) | SignalList |


SimbaProSignals: Klassen-Elemente - Funktionen

  • Auflistung der Klassen
  • Klassen-Elemente
  • Alle
  • Funktionen

  • requireModule() : SignalList
  • SignalList() : SignalList


SimbaProSignals: Erklärung des Graphen

Erklärung des Graphen

Diese Seite erklärt die Interpretation der von doxygen erzeugten Graphen.

Beispiel:

/*! Wegen Verkürzung unsichtbare Klasse */
class Invisible { };

/*! Klasse verkürzt dargestellt, Vererbungsbeziehung ist versteckt */
class Truncated : public Invisible { };

/* Nicht mit doxygen-Kommentaren dokumentierte Klasse */
class Undocumented { };

/*! Mithilfe öffentlicher Vererbung vererbte Klasse */
class PublicBase : public Truncated { };

/*! Eine Template Klasse */
template<class T> class Templ { };

/*! Mithilfe geschützter Vererbung vererbte Klasse */
class ProtectedBase { };

/*! Mithilfe privater Vererbung vererbte Klasse */
class PrivateBase { };

/*! Von der Klasse Inherited benutzte Klasse */
class Used { };

/*! Superklasse, die von mehreren anderen Klassen erbt */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

Setzen des Tags MAX_DOT_GRAPH_HEIGHT in der Konfigurationsdatei auf 240 liefert den folgenden Graphen:

Die Rechtecke in obigem Graphen bedeuten:

  • Ein schwarz gefülltes Rechteck stellt die Struktur oder Klasse dar, für die der Graph erzeugt wurde.
  • Ein Rechteck mit schwarzem Rahmen kennzeichnet eine dokumentierte Struktur oder Klasse.
  • Ein Rechteck mit grauem Rahmen kennzeichnet eine undokumentierte Struktur oder Klasse.
  • Ein Rechteck mit rotem Rahmen kennzeichnet eine dokumentierte Struktur oder Klasse, für die nicht alle Vererbungs-/Enthaltenseinsbeziehungen dargestellt werden. Ein Graph wird gekürzt, wenn er nicht in die angegebenen Schranken passt.
Die Pfeile bedeuten:
  • Ein dunkelblauer Pfeil stellt eine öffentliche Vererbungsbeziehung zwischen zwei Klassen dar.
  • Ein dunkelgrüner Pfeil stellt geschützte Vererbung dar.
  • Ein dunkelroter Pfeil stellt private Vererbung dar.
  • Ein gestrichelter violetter Pfeil bedeutet, dass eine Klasse in einer anderen enthalten ist oder von einer anderen benutzt wird. Am Pfeil stehen die Variable(n), mit deren Hilfe auf die Struktur oder Klasse an der Pfeilspitze zugegriffen werden kann.
  • Ein gestrichelter gelber Pfeil kennzeichnet eine Verknüpfung zwischen einer Template Instanz und der Template Klasse von welcher es abstammt. Neben dem Pfeil sind die Template Parameter aufgeführt.


SimbaProSignals: Hauptseite

SimbaProSignals Dokumentation

0.0.1

Erzeugt am Thu Dec 13 12:56:24 2007 für SimbaProSignals von doxygen 1.5.4


SimbaProSignals: signallist.cpp Quellcode

signallist.cpp

gehe zur Dokumentation dieser Datei
00001
00002 #include "SignalList.h"
00003 SignalList::SignalList(String ^name){
00004
00005 }


SimbaProSignals: signallist.h Quellcode

signallist.h

gehe zur Dokumentation dieser Datei
00001 ref class SignalList
00002 {
00003 public:
00004 SignalList(String ^);
00005 virtual String ^requireModule()=0;
00006 };